Matheus Carcasa Web Gestão de TI / Web / EaD
Desde 2002, seus parceiros na Web.
Enviar
logo

Moodle e PHP7

CONFIGURAÇÕES DE PHP 7.X PARA MOODLE 

O PHP7 foi lançado em 3 de dezembro de 2015 e tem uma melhora significativa no desempenho em comparação ao PHP5. Todo mundo quer se beneficiar dele, no entanto, os padrões de linguagem mudaram e o código escrito para PHP5 pode não funcionar no PHP7. O núcleo e os plugins do Moodle devem modificar o código para que ele funcione da mesma maneira em ambas as versões do PHP.

Esta página contém a descrição do que foi alterado no Moodle para que ele funcione no PHP7 e recomendações para desenvolvedores de plugins. Por favor veja também os problemas épicos MDL-50565 (PHP 7.0), MDL-55120 (PHP 7.1), MDL-60279 (PHP 7.2) e MDL-63420 (PHP 7.3) que combinam todas as mudanças que foram feitas no Moodle para garantir a compatibilidade PHP7. (Nota: você deve estar logado no rastreador para ver problemas em epopeias)

O PHP 7.0 pode ser usado com o Moodle 3.0.1, Moodle 3.1 e versões posteriores. É também a versão mínima suportada para o Moodle 3.4

O PHP 7.1 pode ser usado com o Moodle 3.2 e versões posteriores. É também a versão mínima suportada para o Moodle 3.7

PHP 7.2 pode ser usado com o Moodle 3.4 e versões posteriores

O suporte ao PHP 7.3 está sendo implementado ( MDL-63420 ) para o Moodle 3.6.xe versões posteriores. Por isso, ainda é incompleto e apenas para fins de desenvolvimento.

 

Fonte:

https://docs.moodle.org/dev/Moodle_and_PHP7#Exception_and_Throwable

Publicações relacionadas

Comments are closed.